building

Compiling FlightGear 2.4.0 for Ubuntu Linux 10.04 (Lucid)

2011-08-17
Update 2011-08-26: If you are using Ubuntu 11.04 or later, it looks like this is now packaged as a .deb by PlayDeb. This post may still be of interest to those using earlier versions of Ubuntu. I recently had cause to install FlightGear 2.4.0 on Ubuntu 10.04. It’s not packaged in the form of a deb yet, so I’ve documented the commands I used. No guarantees this’ll work for you, as I haven’t tested them┬árigorously; and I’m assuming some Linux and command-line knowledge.